Security Lab

Несколько уязвимостей в Xcms

Дата публикации:17.01.2008
Всего просмотров:2070
Опасность:
Высокая
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: CVE-2007-6604
CVE-2007-6652
Вектор эксплуатации: Удаленная
Воздействие: Раскрытие важных данных
Раскрытие системных данных
Обход ограничений безопасности
Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: Xcms 1.x
Уязвимые версии: Xcms версии до 1.84.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю получить доступ к важным данным и выполнить произвольный PHP сценарий на целевой системе.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "s" в сценарии index.php (когда параметр "pg" установлен в "admin") и в параметре "pg" в сценарии index.php (когда параметр "mod" установлен в значение существующего модуля). Удаленный пользователь может с помощью специально сформированного запроса, содержащего символы обхода каталога, просмотреть содержимое произвольных файлов на системе. Для удачной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена в конфигурационном файле PHP. Пример:

http://[host]/index.php?pg=admin&s=../../../../../etc/passwd\
http://[host]/index.php?mod=[existing module]&pg=../../../../../etc/passwd\

2. Уязвимость существует из-за некорректного ограничения доступа авторизованным пользователям в сценарии admin/cpie.php. Удаленный пользователь может с помощью HTTP клиента, не поддерживающего перенаправления, выполнить произвольный PHP код на целевой системе с привилегиями Web сервера.

URL производителя: www.xcms.it

Решение: Установите последнюю версию 1.84 с сайта производителя.

Ссылки: XCMS <= 1.83 Remote Command Execution Exploit