Security Lab

PHP-инклюдинг в Kontakt Formular

Дата публикации:14.01.2008
Всего просмотров:1246
Опасность:
Высокая
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: Kontakt Formular 1.x
Уязвимые версии: Kontakt Formular 1.4 до 2008-01-03, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "root_path" в сценарии includes/function.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Пример:

http://[host]/includes/function.php?root_path=[file]

URL производителя: www.mapos-scripts.de/downloads,2.html

Решение: Установите последнюю версию 1.4 от 2008-01-03 с сайта производителя.