Security Lab

PHP-инклюдинг в TalkBack

Дата публикации:22.11.2007
Дата изменения:24.03.2009
Всего просмотров:1289
Опасность:
Высокая
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Раскрытие важных данных
Раскрытие системных данных
Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: TalkBack 2.x
Уязвимые версии: TalkBack 2.2.7, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "config[comments_form_tpl]" в сценарии comments-display-tpl.php и в параметре "language_file" в сценариях comments-display-tpl.php и addons/separate-comments-mod/my-comments-display-tpl.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/comments-display-tpl.php?language_file=[file]
http://[host]/comments-display-tpl.php?config[comments_form_tpl]=[file]
http://[host]/addons/separate-comments-mod/my-comments-display-tpl.php?language_file=[file]

URL производителя: www.scripts.oldguy.us/talkback/

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"