Security Lab

PHP-инклюдинг в GuppY

Дата публикации:08.11.2007
Дата изменения:10.04.2009
Всего просмотров:1135
Опасность:
Высокая
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: CVE-2007-0639
CVE-2007-5844
CVE-2007-5845
Вектор эксплуатации: Удаленная
Воздействие: Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: GuppY 4.x
Уязвимые версии: GuppY 4.6.3, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "selskin" в сценарии includes.inc, подключаемом в файле index.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Пример:

http://[HOST]/[PATH]/index.php?selskin=[LFI]%00
http://[HOST]/[PATH]/index.php?selskin=..%2Finc%2Fboxleft.inc%00&xposbox[L][]=[RFI]

URL производителя: www.freeguppy.org

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
10.04.2009
Изменена секция "Решение"