Security Lab

Несколько уязвимостей в phpBB2 Plus

Дата публикации:24.09.2007
Дата изменения:28.03.2009
Всего просмотров:9312
Опасность:
Высокая
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: CVE-2007-5009
CVE-2007-5100
Вектор эксплуатации: Удаленная
Воздействие: Раскрытие важных данных
Раскрытие системных данных
Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: phpBB2 Plus 1.x
Уязвимые версии: phpBB2 Plus 1.53a до 2007-09-22 и более ранние версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю получить доступ к важным данным и скомпрометировать целевую систему.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "phpbb_root_path" в сценарии language/lang_german/lang_main_album.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Пример:

http://[host]/language/lang_german/lang_main_album.php?phpbb_root_path=[file]

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "phpbb_root_path" в сценариях language/lang_german/lang_admin_album.php, language/lang_english/lang_main_album.php и language/lang_english/lang_admin_album.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для успешной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP.

URL производителя: www.phpbb2.de

Решение: Установите исправленную версию 1.53a с сайта производителя.