Security Lab

PHP-инклюдинг в Joomla joomlaradio компоненте

Дата публикации:17.09.2007
Всего просмотров:5115
Опасность:
Высокая
Наличие исправления: Нет
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Раскрытие важных данных
Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: joomlaradio 5.x (компонент к Joomla)
Уязвимые версии: joomlaradio (компонент к Joomla) 5.0, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "mosConfig_live_site" в сценарии admin.joomlaradiov5.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/administrator/components/com_joomlaradiov5/admin.joomlaradiov5.php?mosConfig_live_site=[file]

URL производителя: www.renevanasten.net/downloads/joomla-components.html

Решение: Способов устранения уязвимости не существует в настоящее время.