Отказ в обслуживании в обработке некорректных заголовков в mod_proxy

Дата публикации:05.09.2007
Дата изменения:20.03.2008
Всего просмотров:2144
Опасность:
Низкая
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Отказ в обслуживании
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: Apache 2.0.x
Apache 2.2.x
Уязвимые версии: Apache 2.0.58, 2.2.4 и более ранние версии

Описание: Уязвимость в модуле mod_proxy позволяет удаленному пользователю вызвать отказ в обслуживании.

Модуль некорректно обрабатывает данные заголовков внутри функции "ap_proxy_date_canon()" в proxy_util.c. В результате можно послать специально обработанный запрос на уязвимый сервер, чтобы вызвать отказ в обслуживании и аварийно завершить работу MPM модуля Apache.

URL производителя: www.apache.org

Решение: Установите последнюю версию 2.0.61 или 2.2.6 с сайта производителя.