Security Lab

PHP-инклюдинг в b1gBB

Дата публикации:26.06.2007
Всего просмотров:1486
Опасность:
Высокая
Наличие исправления: Нет
Количество уязвимостей:1
CVE ID: CVE-2007-3401
CVE-2007-3589
CVE-2007-3590
Вектор эксплуатации: Удаленная
Воздействие: Межсайтовый скриптинг
Раскрытие важных данных
Неавторизованное изменение данных
Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: b1gBB 2.x
Уязвимые версии: b1gBB 2.24.0, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "tfooter" в сценарии footer.inc.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/path/footer.inc.php?tfooter=[file]

URL производителя: sourceforge.net/projects/b1gbb

Решение: Способов устранения уязвимости не существует в настоящее время.