Security Lab

PHP-инклюдинг в cjgExplorerPro

Дата публикации:15.05.2007
Всего просмотров:1624
Опасность:
Высокая
Наличие исправления: Нет
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Раскрытие важных данных
Раскрытие системных данных
Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: cjgExplorerPro 3.x
Уязвимые версии: cjgExplorerPro 3.3, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "g_pcltar_lib_dir" в сценарии lib/pcltar.lib.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/cep/lib/pcltar.lib.php?g_pcltar_lib_dir=[file]

URL производителя: cjgexplorerpro.com.ar

Решение: Способов устранения уязвимости не существует в настоящее время.