Security Lab

PHP-инклюдинг в AROUNDMe

Дата публикации:10.04.2007
Всего просмотров:1955
Опасность:
Высокая
Наличие исправления: Нет
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: AROUNDMe 0.x
Уязвимые версии: AROUNDMe 0.7.7, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "language_path_core" в сценарии components/core/inc/core_profile.header.php, в параметре "template_path_core" в сценарии components/core/template/barnraiser_01/maint_contact_view.tpl.php и в параметре "template_path" в сценарии components/core/template/barnraiser_01/default.tpl.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Примеры:

http://[host]/path/aroundme/components/core/inc/core_profile.header.php?language_path_core=[file]
http://[host]/path/components/core/template/barnraiser_01/maint_contact_view.tpl.php?template_path_core=[file]
http://[host]/path/components/core/template/barnraiser_01/default.tpl.php?template_path=[file]
http://[host]/path/components/core/template/barnraiser_01/maint_contact_view.tpl.php?template_path_core=[file]

URL производителя: www.barnraiser.org

Решение: Способов устранения уязвимости не существует в настоящее время.