Security Lab

Межсайтовый скриптинг в Mozilla Firefox Firebug Extension

Дата публикации:05.04.2007
Всего просмотров:3586
Опасность:
Высокая
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: CVE-2007-1878
CVE-2007-1947
Вектор эксплуатации: Удаленная
Воздействие: Межсайтовый скриптинг
Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: Firebug (расширение к Mozilla Firefox) 1.x
Уязвимые версии: Firebug (расширение к Mozilla Firefox) версии до 1.02.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных, передаваемых функции "console.log()". Удаленный пользователь может с помощью специально сформированного Web сайта выполнить произвольный код сценария в браузере жертвы в контексте "chrome:".

URL производителя: https://addons.mozilla.org/en-US/firefox/addon/1843

Решение: Установите последнюю версию (1.02) с сайта производителя.

Ссылки: Firebug Goes Evil