Security Lab

PHP-инклюдинг в SMA-DB

Дата публикации:08.02.2007
Дата изменения:05.02.2009
Всего просмотров:2246
Опасность:
Высокая
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: SMA-DB 0.x
Уязвимые версии: SMA-DB 0.3.9, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "pfad_z" в сценарии theme/settings.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/theme/settings.php?pfad_z=[file]

URL производителя: people.ee.ethz.ch/~dmaeder/bluevirus/main.php?tpc=programs

Решение: Установите последнюю версию 0.3.12 с сайта производителя.

Журнал изменений:

05.02.2009
Изменена секция «Решение».

Ссылки: http://milw0rm.com/exploits/3268