Security Lab

PHP-инклюдинг в MyNews

Дата публикации:05.02.2007
Дата изменения:04.02.2007
Всего просмотров:1206
Опасность:
Высокая
Наличие исправления: Нет
Количество уязвимостей:1
CVE ID: CVE-2007-0633
CVE-2007-2014
Вектор эксплуатации: Удаленная
Воздействие: Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: MyNews CMS 4.x
Уязвимые версии: MyNews 4.2.2, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "myNewsConf[path][sys][index]" в сценарии themes/themefunc.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP.

URL производителя: mynews.alienated.org

Решение: Способов устранения уязвимости не существует в настоящее время.