Межсайтовый скриптинг в phpBB

Дата публикации:09.12.2006
Всего просмотров:11550
Опасность:
Низкая
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: CVE-2006-6421
CVE-2006-6508
CVE-2006-6841
Вектор эксплуатации: Удаленная
Воздействие: Межсайтовый скриптинг
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: phpBB 2.x
Уязвимые версии: phpBB 2.0.21, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение и CSRF атаку.

1. Уязвимость существует из-за того, что приложение не проверяет валидность HTTP запроса при отправке сообщений. Злоумышленник может с помощью специально сформированной Web страницы отправить пользователям произвольные сообщения.

2. Уязвимость существует из-за недостаточной обработки входных данных в поле "Message body" в сценарии privmsg.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.phpbb.com

Решение: Способов устранения уязвимости не существует в