Security Lab

Повреждение памяти в GnuPG

Дата публикации:08.12.2006
Всего просмотров:1425
Опасность:
Высокая
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: GnuPG / gpg 1.2.x
GnuPG / gpg 1.0.x
GnuPG / gpg 1.3.x
GnuPG / gpg 1.4.x
GnuPG / gpg 2.x
Уязвимые версии: GnuPG / gpg версии до 1.4.6 и 2.0.2.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки при дешифровке злонамеренных OpenPGP сообщений. Удаленный пользователь может с помощью специально сформированого OpenPGP сообщения вызвать повреждение памяти и выполнить произвольный код на целевой системе.

URL производителя: www.gnupg.org

Решение: Установите последнюю версию с сайта производителя.