Security Lab

PHP-инклюдинг в Advanced Guestbook

Дата публикации:08.11.2006
Всего просмотров:4993
Опасность:
Высокая
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: Advanced Guestbook 2.x
Уязвимые версии: Advanced Guestbook 2.3.1, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "include_path" в сценарии admin.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера.

URL производителя: www.proxy2.de/scripts.php

Решение: Установите последнюю версию (2.4.2) с сайта производителя.