Security Lab

Множественные уязвимости в Hosting Controller

Дата публикации:01.11.2006
Всего просмотров:2615
Опасность:
Средняя
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: CVE-2006-5629
CVE-2006-5630
Вектор эксплуатации: Удаленная
Воздействие: Неавторизованное изменение данных
Обход ограничений безопасности
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: Hosting Controller 6.x
Уязвимые версии: Hosting Controller 6.1 Hotfix 3.2, возможно более ранние версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "ForumID" в сценариях DisableForum.asp и EnableForum.asp. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Пример:

http://[host]/forum/HCSpecific/DisableForum.asp?action=disableforum&ForumID=1 or 1=1
http://[host]/forum/HCSpecific/EnableForum.asp?action=enableforum&ForumID=1 or 1=1

2. Уязвимость существует из-за ошибки проверки прав пользователя при доступе к определенным сценариям. Удаленный пользователь может создать и удалить виртуальные директории произвольных сайтов с помощью сценариев DisableForum.asp и EnableForum.asp. Пример:

http://[host]/forum/HCSpecific/DisableForum.asp?action=disableforum&WSiteName=testsite.com&VDirName=test&ForumID=1
http://[host]/forum/HCSpecific/EnableForum.asp?action=enableforum&WSiteName=testsite.com&VDirName=test&ForumID=

URL производителя: hostingcontroller.com

Решение: Установите исправление (Hotfix 3.2) с сайта производителя.

Ссылки: Hosting Controller 6.1 Hotfix <= 3.2 Multi Vuln