Security Lab

Межсайтовый скриптинг в cPanel

Дата публикации:26.10.2006
Всего просмотров:3884
Опасность:
Низкая
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Межсайтовый скриптинг
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: cPanel 10.x
Уязвимые версии: cPanel 10.9.0 R50, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "theme" в сценарии scripts/dosetmytheme, и в параметре "template" в сценарии scripts2/editzonetemplate в WebHost Manager. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.cpanel.net

Решение: Установите последнюю версию (10.9.0 R56 или выше) с сайта производителя.