Security Lab

PHP-инклюдинг в Net_DNS

Дата публикации:25.10.2006
Всего просмотров:2046
Опасность:
Высокая
Наличие исправления: Нет
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: Net_DNS 0.x
Уязвимые версии: Net_DNS 0.3, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "phpdns_basedir" в сценарии DNS/RR.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP.

URL производителя: pear.php.net/package/Net_DNS

Решение: Способов устранения уязвимости не существует в настоящее время.