Security Lab

PHP-инклюдинг в OTSCMS

Дата публикации:25.10.2006
Всего просмотров:1244
Опасность:
Высокая
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: CVE-2006-5546
CVE-2006-5547
CVE-2006-5548
Вектор эксплуатации: Удаленная
Воздействие: Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: OTSCMS 2.x
Уязвимые версии: OTSCMS версии до 2.1.4.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "GLOBALS[config][directories][classes]" в сценарии OTSCMS.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP.

URL производителя: otscms.com

Решение: Установите последнюю версию (2.1.4) с сайта производителя.

Ссылки: OTSCMS <= 2.1.3 Multiple Remote File Include Vulnerabilities