Security Lab

PHP-инклюдинг в WebYep

Дата публикации:10.10.2006
Дата изменения:24.03.2009
Всего просмотров:1483
Опасность:
Высокая
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: WebYep 1.x
Уязвимые версии: WebYep 1.1.9, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "webyep_sIncludePath" в различных сценариях. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Пример:

http://[host]/[webYep_path]/webyep-system/programm/lib/WYApplication.php?webyep_sIncludePath=[file]
http://[host]/[webYep_path]/webyep-system/programm/lib/WYDocument.php?webyep_sIncludePath=[file]
http://[host]/[webYep_path]/webyep-system/programm/webyep.php?webyep_sIncludePath=[file]
http://[host]/[webYep_path]/webyep-system/programm/elements/WYGalleryElement.php?webyep_sIncludePath=[file]

URL производителя: www.obev.at/products/webyep/

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: WebYep <= 1.1.9 (webyep_sIncludePath) Multiple Remote File Inclusion Vulnerability