Security Lab

Несколько уязвимостей в скрипте для ведения блогов Blog PixelMotion

Дата публикации:29.09.2006
Всего просмотров:2347
Опасность:
Высокая
Наличие исправления: Нет
Количество уязвимостей:1
CVE ID: CVE-2006-5085
CVE-2006-5086
Вектор эксплуатации: Удаленная
Воздействие: Неавторизованное изменение данных
Обход ограничений безопасности
Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: Blog PixelMotion 2.x
Уязвимые версии: Blog PixelMotion 2.1.1, возможно более ранние версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю обойти некоторые ограничения безопасности и скомпрометировать целевую систему.

1. Уязвимость существует из-за недостаточной обработки входных данных в различных параметрах в сценарии "config.php". Удаленный пользователь может внедрить произвольный PHP код в файл include/variables.php.

2. Сценарий insere_base.php выполняет некоторые действия посредством HTTP GET запросов без проверки на наличие привилегий доступа. Удаленный пользователь может изменить личные данные администратора путем вставка данных в параметры "login" и "pass".

URL производителя: pixelmotion.org

Решение: Способов устранения уязвимости не существует в настоящее время.