Security Lab

PHP-инклюдинг в Shadowed Portal

Дата публикации:18.09.2006
Дата изменения:17.10.2006
Всего просмотров:1887
Опасность:
Высокая
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: CVE-2006-4885
CVE-2006-4826
Вектор эксплуатации: Удаленная
Воздействие: Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: Shadowed Portal 5.x
Уязвимые версии: Shadowed Portal 5.51, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "root" в сценариях bottom.php, footer.php и header.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP.

URL производителя: shad0wed.com

Решение: Установите последнюю версию (5.6 или выше) с сайта производителя.