Security Lab

PHP-инклюдинг в PHProjekt

Дата публикации:17.08.2006
Дата изменения:24.03.2009
Всего просмотров:2554
Опасность:
Высокая
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: PHProjekt 5.x
Уязвимые версии: PHProjekt 5.1, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "path_pre" в сценарии lib/specialdays.php и в параметре "lib_path" в сценарии lib/dbman_filter.inc.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера.

URL производителя: phprojekt.com

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"