Security Lab

Переполнение буфера в wodSSHServer

Дата публикации:16.05.2006
Дата изменения:24.03.2009
Всего просмотров:2048
Опасность:
Высокая
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: wodSSHServer ActiveX Component 1.x
Уязвимые версии: wodSSHServer 1.2.7 и 1.3.3 DEMO. Возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных при обработке строки алгоритма для обмена ключом, полученным от SSH клиента. Удаленный пользователь может вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.weonlydo.com/index.asp?showform=SSHServer

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"