Security Lab

PHP-инклюдинг в KnowledgebasePublisher

Дата публикации:27.03.2006
Дата изменения:17.10.2006
Всего просмотров:1526
Опасность:
Высокая
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: KnowledgebasePublisher 1.x
Уязвимые версии: KnowledgebasePublisher 1.2 и более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "dir" сценария PageController.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web севрера.

URL производителя: kbpublisher.sourceforge.net

Решение: Установите последнюю версию (1.2.1) с сайта производителя.