Security Lab

PHP-инклюдинг в AppServ

Дата публикации:09.01.2006
Всего просмотров:16710
Опасность:
Высокая
Наличие исправления: Нет
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: AppServ 2.x
Уязвимые версии: AppServ 2.4.5, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "appserv_root" сценария "appserv/main.php". Удаленный пользователь может с помощью специально сформированного URL выполнить произвольный PHP сценарий на системе с привилегиями Web сервера.

URL производителя: www.appservnetwork.com

Решение: Способов устранения уязвимости не существует в настоящее время.

Источник:

Ссылки: AppServ "appserv_root" File Inclusion Vulnerability