Security Lab

PHP-инклюдинг в phpBook

Дата публикации:04.01.2006
Дата изменения:17.10.2006
Всего просмотров:7754
Опасность:
Высокая
Наличие исправления: Нет
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: phpBook 1.x
Уязвимые версии: phpBook 1.3.2 и более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на системе.

Уязвимость существует из-за недостаточной фильтрации входных данных в параметре "email". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP код на целевой системе с привилегиями Web севера. Пример:

E-mail field: qwe@<? anyphpcode(); ?>.com

URL производителя: sourceforge.net/projects/phpbook/

Решение: Способов устранения уязвимости не существует в настоящее время.

Источник:

Ссылки: phpBook PHP Code Execution