Security Lab

SQL-инъекция в PHPX

Дата публикации:05.12.2005
Дата изменения:10.11.2008
Всего просмотров:1632
Опасность:
Высокая
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Неавторизованное изменение данных
Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: PHPX 3.x
Уязвимые версии: PHPX 3.5.9 и более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

Уязвимость существует из-за недостаточной обработки входных данных в поле "username" формы доступа к административному интерфейсу. Удаленный пользователь может с помощью специально сформированного HTTP POST запроса выполнить произвольные SQL команды в базе данных приложения. Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена и в конфигурационном файле PHP. Дальнейшая эксплуатация уязвимости может позволить злоумышленнику получить доступ к административному интерфейсу приложения и выполнить произвольный PHP код на целевой системе с привилегиями Web сервера.

URL производителя: www.phpx.org

Решение: Установите исправление с сайта производителя.

Ссылки: PHPX "username" SQL Injection Vulnerability