Межсайтовый скриптинг в VP-ASP Shopping Cart

Дата публикации:25.11.2005
Дата изменения:24.03.2009
Всего просмотров:2353
Опасность:
Низкая
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Межсайтовый скриптинг
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: VP-ASP Shopping Cart 5.x
Уязвимые версии: VP-ASP Shopping Cart 5.50, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует при обработке входных данных в параметре "UserName" сценария "shopadmin.asp". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный HTML код в браузере жертвы в контексте безопасности уязвимого сайта.

Пример/Эксплоит: см. источник сообщения.

URL производителя: www.vpasp.com

Решение: Установите последнюю версию с сайта производителя.

Источник:

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: VP-ASP Shopping Cart Cross Scripting vulnerability