Межсайтовый скриптинг в Struts

Дата публикации:24.11.2005
Дата изменения:29.03.2008
Всего просмотров:2472
Опасность:
Низкая
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Межсайтовый скриптинг
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: Apache Struts 1.2.x
Уязвимые версии: Struts 1.2.7

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной фильтрации входных данных, которые возвращаются пользователю в качестве 404 ошибки. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный HTML код в браузере жертвы в контексте безопасности уязвимого сайта. Пример:

http://[host]/[code].do

URL производителя: http://struts.apache.org

Решение: Установите последнюю версию 1.2.8 с сайта производителя.

Ссылки: Struts Error Message Cross Site Scripting