Выполнение произвольных команд в PEAR

Дата публикации:21.11.2005
Дата изменения:17.10.2006
Всего просмотров:1373
Опасность:
Наличие исправления:
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации:
Воздействие:
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты:
Уязвимые версии: PEAR 1.4.2 и более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю обойти ограничения безопасности.

Уязвимость существует из-за ошибки в дизайне в инсталляторе PEAR. Удаленный пользователь может создать специально сформированный пакет и выполнить произвольный PHP сценарий на целевой системе.

URL производителя: pear.php.net

Решение: Установите последнюю версию (1.4.3) с сайта производителя.

Источник:

Ссылки: PEAR installer arbitrary code execution vulnerability