Множественные уязвимости в phpAdsNew и phpPgAds

Дата публикации:14.11.2005
Дата изменения:09.02.2009
Всего просмотров:1984
Опасность:
Средняя
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Межсайтовый скриптинг
Раскрытие системных данных
Неавторизованное изменение данных
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: Openads for PostgreSQL (ранее phpPgAds) 2.x
OpenX (ранее Openads и phpAdsNew) 2.x
Уязвимые версии:
phpAdsNew 2.0.6 и более ранние версии
phpPgAds 2.0.6 и более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение, выполнить произвольные SQL команды в базе данных приложения и получит доступ к некоторым данным.

1. Уязвимость обнаружена при обработке входных данных в параметре файла куки "sessionID" в сценариях "logout.php" и "index.php". Удаленный пользователь может с помощью специально сформированного файла куки выполнить произвольные SQL команды в базе данных приложения. Для успешной эксплуатации уязвимости, опция magic_quotes_gpc должна быть выключена.

2. Удаленный пользователь может непосредственно запросить сценарий "misc/revisions/create.php" и получить данные об установочной директории приложения на системе.

3. Уязвимость существует из-за недостаточной обработки входных данных. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: phpadsnew.com

Решение: Установите последнюю версию (2.0.7) с сайта производителя.

Журнал изменений:

09.02.2009
Изменено описание уязвимостей.

Ссылки: Multiple vulnerabilities in phpAdsNew

http://sourceforge.net/project/showfiles.php?group_id=11386