SQL-инъекция в SaphpLesson

Дата публикации:26.10.2005
Дата изменения:24.03.2009
Всего просмотров:1262
Опасность:
Средняя
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: CVE-2005-3363
CVE-2006-1420
CVE-2006-2835
Вектор эксплуатации: Удаленная
Воздействие: Неавторизованное изменение данных
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: SaphpLesson 2.x
Уязвимые версии: SaphpLesson 2.x

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

Уязвимость существует при обработке входных данных в параметре forumid в сценариях showcat.php и add.php. Удаленный пользователь может с помощью специально сформированного URL выполнить произвольные SQL команды в базе данных приложения.

Пример/Эксплоит:
SaphpLesson 2.0 (forumid) Remote SQL Injection Exploit

Решение: Установите последнюю версию с сайта производителя.

Источник:

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: SaphpLesson forumid SQL Injection Vulnerability