Security Lab

Переполнение буфера в Lynx при обработке NNTP сообщений

Дата публикации:18.10.2005
Дата изменения:28.10.2008
Всего просмотров:1883
Опасность:
Высокая
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: Lynx 2.x
Уязвимые версии: Lynx 2.8.3, 2.8.4, 2.8.5,and 2.8.6dev.13

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость обнаружена в функции HTrjis() при обработке заголовков сообщений. Злоумышленник может заставить пользователя посетить злонамеренный NNTP сервер и выполнить произвольный код на целевой системе с привилегиями текущего пользователя.

Пример/Эксплоит:
Lynx Browser NNTP Handling Remote Buffer Overflow PoC Exploit

URL производителя: lynx.isc.org

Решение: Установите последнюю версию (2.8.6dev.14) с сайта производителя.

Ссылки: Lynx Remote Buffer Overflow