Целочисленное переполнение в Python PCRE

Дата публикации:15.09.2005
Дата изменения:17.10.2006
Всего просмотров:1811
Опасность:
Средняя
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Отказ в обслуживании
Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: Python 2.2.x
Python 2.3.x
Уязвимые версии: Python версии до 2.3.5

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за того, что Python использует уязвимую библиотеку PCRE. Удаленный пользователь может выполнить произвольный код на целевой системе.

URL производителей: www.python.org

Решение: Установите последнюю версию с сайта производителя..

Ссылки: Python: Heap overflow in the included PCRE library