Отказ в обслуживании в Snort (обновлено)

Дата публикации:15.09.2005
Всего просмотров:2623
Опасность:
Средняя
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Отказ в обслуживании
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: Snort 2.4.x
Уязвимые версии: Snort 2.4.0 и более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании приложения.

Уязвимость существует в функции PrintTcpOptions() файла snort-2.4.0/src/log.c из-за ошибки в нулевом указателе разыменования. Удаленный пользователь может послать приложению TCP/IP пакет со специально сформированной опцией TCP SACK и вызвать отказ в обслуживании. Успешная эксплуатация уязвимости требует, чтобы Snort был запущен с ключом ‘-v’.

Пример/Эксплоит:
Snort <= 2.4.0 SACK TCP Option Handling Remote Denial of Service Exploit

URL производителей: www.snort.org

Решение: Установите последнюю версию (2.4.1), доступную по CVS.

Ссылки: Snort <= 2.4.0 SACK TCP Option Error Handling