Security Lab

PHP инклюдинг в WebCalendar

Дата публикации:05.09.2005
Дата изменения:04.09.2005
Всего просмотров:2730
Опасность:
Критическая
Наличие исправления:
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации:
Воздействие:
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты:
Уязвимые версии: WebCalendar версии до 1.0.1

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре 'includedir' файла 'includes/functions.php'. Удаленный пользователь может с помощью специально сформированного URL выполнить произвольный PHP сценарий на целевой системе с привилегиями web сервера.

URL производителей: www.k5n.us/webcalendar.php

Решение: Установите последнюю версию (1.0.1) с сайта производителя.

Ссылки: WebCalendar: Release Notes