PHP-инклюдинг в iPhotoAlbum

Дата публикации:13.07.2005
Всего просмотров:1521
Опасность:
Высокая
Наличие исправления: Нет
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: iPhotoAlbum 1.x
Уязвимые версии: iPhotoAlbum 1.1

Описание:
Обнаруженная уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре doc_path сценария getpage.php, и параметре set_menu сценария header.php. Удаленный пользователь может с помощью специально сформированного URL выполнить произвольный PHP сценарий на целевой системе с привилегиями web сервера.

Решение: Способов устранения уязвимости не существует в настоящее время.