Security Lab

Обход ограничений безопасности в phpSlash

Дата публикации:11.07.2005
Дата изменения:04.02.2009
Всего просмотров:977
Опасность:
Средняя
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Обход ограничений безопасности
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: phpSlash 0.x
Уязвимые версии: phpSlash версии до 0.8.1

Описание:
Уязвимость позволяет удаленному авторизованному пользователю обойти ограничений безопасности и завладеть учетной записью целевого пользователя.

Уязвимость существует из-за некорректно применения прав доступа в функции saveProfile() компонента 'Author.class::saveProfile'. Удаленный авторизованный пользователь с привилегиями на 'AuthorSaveProfile' может изменить личные данные целевого пользователя – имя пользователя, e-mail, URL, пароль.

URL производителя: www.php-slash.org

Решение: Установите последнюю версию 0.8.1 с сайта производителя.

Ссылки: phpSlash account hijacking vulnerability

http://sourceforge.net/project/showfiles.php?group_id=10566