Переполнение буфера в zlib при обработке сжатых потоков данных

Дата публикации:08.07.2005
Дата изменения:15.08.2008
Всего просмотров:1678
Опасность:
Средняя
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Отказ в обслуживании
Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: zlib 1.x
Уязвимые версии: zlib 1.2.2

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании или выполнить произвольный код на целевой системе.

Уязвимость существует в функции inflate_table() файла 'inftrees.c'. Удаленный пользователь может создать специально сформированный архив, который вызовет переполнение буфера и аварийно завершит приложение или выполнит произвольный код на системе с привилегиями текущего пользователя.

URL производителя: www.gzip.org/zlib/

Решение: Установите последнюю версию 1.2.3 с сайта производителя.

Ссылки: Zlib Buffer Overflow in inflate_table() May Let Remote Users Execute Arbitrary Code