Отказ в обслуживании в Linux kernel ELF загрузчике

Дата публикации:04.04.2005
Всего просмотров:1371
Опасность:
Низкая
Наличие исправления:
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации:
Воздействие:
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты:
Уязвимые версии: Linux kernel 2.4 - 2.4.30-rc2; 2.6 версии до 2.6.11.6

Описание:
Уязвимость позволяет локальному пользователю вызвать отказ в обслуживании.

Уязвимость обнаружена в файле '/fs/binfmt_elf.c'. Локальный пользователь может вызвать load_elf_library и изменить значении для 'elf_phdata', что приведет к освобождению чужой памяти. Локальный пользователь может вызвать отказ в обслуживании системы.

URL производителя: kernel.org

Решение: Установите последнюю версию от производителя.

Ссылки: Linux Kernel Bug in load_elf_library Lets Local Users Deny Service