Security Lab

Удаленное выполнение произвольного кода в xpcd

Дата публикации:14.02.2005
Дата изменения:16.10.2006
Всего просмотров:1038
Опасность:
Высокая
Наличие исправления:
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации:
Воздействие:
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты:
Уязвимые версии: xpcd 2.09 и более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю вызвать переполнение буфера и выполнить произвольный код на удаленной системе.

Уязвимость обнаружена в файлах 'test/view.c' и 'xpcd/complete.c'. Удаленный пользователь может с помощью специально сформированных данных (например, имени файла), вызвать переполнение буфера и выполнить произвольный код на уязвимой системе с привилегиями пользователя root.

URL производителя: http://linux.bytesex.org/fbida/xpcd.html

Решение: Установите обновление от производителя.

Ссылки: xpcd Buffer Overflow in Processing Filenames Lets Remote Users Execute Arbitrary Code With Root Privileges