Межсайтовое выполнение сценариев в PHProxy

Дата публикации:29.12.2004
Дата изменения:17.10.2006
Всего просмотров:2982
Опасность:
Низкая
Наличие исправления:
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации:
Воздействие:
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты:
Уязвимые версии: PHProxy 0.3 и более ранние версии

Описание:
Обнаружено межсайтовое выполнение сценариев в PHProxy. Удаленный атакующий может получить доступ к важным данным пользователей.

Уязвимость обнаружена при обработке входных данных пользователей в параметре 'error'. Удаленный атакующий может создать специально сформированный URL и выполнить произвольный HTML код в браузере целевого пользователя. Пример:

http://[target]/poxy/index.php?error=html%20code%20could%20be%20easily%20injected%20here

URL производителя: www.whitefyre.com/poxy/

Решение: Решение не существует на данный момент.