Обход ограничений в JSBoard

Дата публикации:21.12.2004
Дата изменения:17.10.2006
Всего просмотров:1132
Опасность:
Высокая
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: JSBoard 1.x
JSBoard 2.x
Уязвимые версии: JSBoard 2.x - 2.0.8; 1.x - 1.3.11

Описание:
Обнаружена уязвимость в JSBoard. Удаленный атакующий может загрузить и выполнить произвольный сценарий на уязвимой системе.

Уязвимость существует из-за некорректной фильтрации расширений файлов в сценарии 'include/parse.php'. Удаленный атакующий может загрузить файл, содержащий произвольный сценарий и выполнить его с правами текущего web сервера.

URL производителя: webnegar.co.sr

Решение: Установите обновления
http://kldp.net/frs/download.php/1670/jsboard-2.0.9.tar.gz

http://kldp.net/frs/download.php/1668/jsboard-1.3.13.tar.gz

Ссылки: Vulnerability of uploading files with multiple extensions in JSBoard