Security Lab

Несколько уязвимостей в libpng

Дата публикации:05.08.2004
Дата изменения:03.05.2008
Всего просмотров:1219
Опасность:
Высокая
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: CVE-2004-0597
CVE-2004-0598
CVE-2004-0599
Вектор эксплуатации: Удаленная
Воздействие: Отказ в обслуживании
Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: libpng 1.x
Уязвимые версии: libpng версии до 1.2.6

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

1. Уязвимость существует из-за ошибки разыменования нулевого указателя при обработке PNG файлов. Удаленный пользователь может с помощью специально сформированного PNG файла вызвать отказ в обслуживании приложения, использующего уязвимую библиотеку.

2. Уязвимость существует из-за ошибки проверки границ данных при обработке PNG изображений. Удаленный пользователь может с помощью специально сформированного PNG изображения вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.libpng.org/pub/png/libpng.html

Решение: Установите последнюю версию 1.2.6 с сайта производителя.

Ссылки: CAN-2004-0597 - CAN-2004-0599