PHP-инклюдинг в phpShop

Дата публикации:11.05.2004
Дата изменения:29.09.2008
Всего просмотров:977
Опасность:
Высокая
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: phpShop 0.x
Уязвимые версии: phpShop 0.7.1, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных. Удаленный пользователь может с помощью специально сформированного запроса перезаписать параметр "base_dir" и выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть отключена в конфигурационном файле PHP.

URL производителя: www.phpshop.org

Решение: Установите последнюю версию 0.8.0 с сайта производителя.

Ссылки: Arbitrary code inclusion in phpShop