Множественные уязвимости в PHPX

Дата публикации:05.05.2004
Дата изменения:10.11.2008
Всего просмотров:772
Опасность:
Средняя
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Межсайтовый скриптинг
Обход ограничений безопасности
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: PHPX 3.x
Уязвимые версии: PHPX 3.2.6 и более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и обойти некоторые ограничения безопасности.

1. Уязвимость существует из-за недостаточной обработки входных данных в различных сценариях. Удаленный пользователь может с помощью специально сформированного запросы выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки ссылок на изображения в частных сообщениях. Изображения могут содержать административные функции, которые будут выполнены во время просмотра специально сформированного изображения.

URL производителя: www.phpx.org

Решение: Установите последнюю версию 3.3.1 с сайта производителя.

Ссылки: Vulnerabilities In PHPX 3.26 And Earlier