Повышение привилегий в ncpfs в ядре Linux

Дата публикации:19.02.2004
Дата изменения:01.02.2010
Всего просмотров:1289
Опасность:
Низкая
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Локальная
Воздействие: Повышение привилегий
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: Linux Kernel 2.4.x
Linux Kernel 2.6.x
Уязвимые версии: Linux kernel версии до 2.4.25 и 2.6.3

Описание:
Уязвимость позволяет локальному пользователю повысить свои привилегии на системе.

Уязвимость существует из-за ошибки проверки границ данных в функции ncp_lookup() в службе ncpfs. Локальный пользователь может с помощью слишком длинного имени компонента вызвать переполнение стека и выполнить произвольный код на целевой системе с повышенными привилегиями.

URL производителя: www.kernel.org

Решение: Установите последнюю версию ядра 2.4.25 или 2.6.3 с сайта производителя.

Журнал изменений:

01.02.2010
Обновлено описание уязвимости, понижен рейтинг опасности.